2

Prolem:

I am using ExpressionEngine Core 2.6.1. After I click around the control panel for a bit, sometimes updating templates and sometimes uploading images, I get kicked out. When I get kicked out, instead of just logging me out and showing the login screen, my browser tells me that there is no data available. This is the message that Chrome sends:

Unable to load the webpage because the server sent no data. Error code: ERR_EMPTY_RESPONSE


Solutions I've tried:

I have tried in Chrome, Firefox, and Safari, and the same thing is happening everytime. It usually happens when I repeat the same action about 3 or 4 times (i.e. I upload 4 images, or I update a template 4 times in a row). I try to refresh my browser, clear browsing data, etc. and it keeps showing no data for about 1-2 minutes. After 1-2 minutes, I refresh and the login screen will show up again and I can log in. Throughout the whole process, the front end of my site loads images and displays perfectly fine.

My Control Panel Session Type is set to 'Cookies and Session ID', and my User Session Type is set to cookies only.

After doing some research and finding, not the exact but, a similar issue here Keep Getting Logged Out of Control Panel, I added the following sections of code to my config.pfp file:

$config['cookie_domain'] = "";
$config['cookie_path'] = "";
$config['cookie_prefix'] = "someprefix";
$config['require_ip_for_login'] = "n";
$config['require_ip_for_posting'] = "n";
$config['secure_forms'] = "n";

and

$config['cp_session_ttl'] = 14400;
$config['user_session_ttl'] = 3600;

In regards to the ERR_EMPTY_RESPONSE code, I found this help thread. http://ellislab.com/forums/viewthread/178569/ I tried putting php_value memory_limit 128M into my htaccess file, but that causes my site to have an error. Maybe I'm not adding it correctly? Should I be putting this within any tags in my htaccess file?

It seems that nothing is fixing the issue. This is happening very frequently and disrupting my work flow.

  • Also a note - every time i add a new channel entry, i get kicked out too. But I can edit an old entry without getting kicked out. – jennetcetera Aug 21 '13 at 2:26
  • What host are you using? – Jeremy Gimbel Sep 9 '13 at 19:36
  • I've been using GoDaddy, however the problem resolved itself... weird. – jennetcetera Sep 11 '13 at 15:52
0

After a couple of days I am having no more trouble. The issue resolved itself somehow, but I have a hunch that it had something to do with my hosting. If anyone else has this problem, contacting the host would be the next step I would take.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.