1

My company’s name has an ampersand in it, so you can imagine it appears quite frequently in tags. The tag displays correctly on the page, but clicking it always leads you to a page with no results. There should be some urlencode going on in the plugin to allow for things like this.

Is my only option to modify the Tag add-on myself to urlencode links and urldecode on the results page?

1 Answer 1

1

Are you using the {websafe_tag} param to create your links? http://www.solspace.com/docs/tag/tags/#websafe_tag

5
  • I sure am. <li><a href="{path='blog/tag'}/{websafe_tag}" title="{tag}">{tag}</a></li> Aug 22, 2013 at 14:11
  • I can't reproduce this with a tag containing an ampersand. {websafe_tag} works fine to pull entries using {exp:tag:entries}. What version of Tag and EE are you using? You might also want to check your EE allowed characters and .htaccess settings.
    – Solspace
    Aug 22, 2013 at 20:09
  • My permitted_uri_chars are set to default ($config['permitted_uri_chars'] = 'a-z 0-9~%.:_\\-';). I tried adding an ampersand but it didn't help. EE version is 2.6.1, and Tag version is 4.2.3. Aug 22, 2013 at 21:32
  • Think we'll have to dig in. Please contact us from solspace.com with CP and FTP credentials, and we'll have a look. Please mention this thread as well if possible. Thanks :)
    – Solspace
    Aug 22, 2013 at 22:53
  • Was there a solution found for this issue? Mar 17, 2015 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.