0

I am trying to add a captcha to a site that is running EE 2.6.1. I am using solspace freeform 4.0.12 (the free version, not pro) and accessible captcha 2.3. The code for the captcha is

<tr>
    <td colspan="2" style="margin-left:144;">
        {if captcha}
            <p>{captcha}<br /> <input type="text" name="captcha" value="" size="20" maxlength="20" style="width:140px;" /></p>
        {/if}
    </td>
</tr>

When I remove the {if captcha} tags, the question/answer pair shows up, but it also allows the form to be submitted with an incorrect or missing answer.

I have also tested the page on multiple browsers to make sure that I'm not logged in.

Any suggestions?

  • Solspace respects the native captcha preferences you have setup in EE, whether member or not. You can override this by adding require_captcha="yes" as a parameter on your form tag. Do you have that in place now? Also, shouldn't it be {freeform:captcha} and not just {captcha} (namespacing it to freeform specifically)? – Jean St-Amand Aug 22 '13 at 19:55
3

For our FreeForm forms, we use the following code:

{if freeform:captcha}
      {freeform:captcha}<input type="text" name="captcha" style="width:140px;" />
{/if}
  • Thanks. I didn't realize that freeform was required in the if tag. – lucky.hooligan Aug 27 '13 at 17:33
  • 0 down vote I have exact same problem, but using EE channel form with settings set to ON and correct folder permission. The bots are really picking a speed with spams. – Vladyn Jun 24 '16 at 13:40
  • I have exact same problem, but using EE channel form with settings set to ON and correct folder permission. The bots are really picking a speed with spams. – Vladyn Jun 26 '16 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.