1

Good afternoon,

after upgrading to the latest wygwam version i experienced the problem that the editor is stripping out content from wygwam fields. Not the visible parts but class and id fields from for example ul and li fields.

Most likely the new Advanced Content Filter (ACF) ckeditor implemented is the root cause of this because they have switched it to default on. Problem is that there doesn't seem to that pixel and tonic didn't update the ADVANCED SETTINGS tab so you can disable ACF, only add extraAllowedContent.

My question is, how do i disable ACF? I must set CKEDITOR.config.allowedContent to true to do this but WHERE?

http://docs.ckeditor.com/#!/guide/dev_advanced_content_filter

4

You can disable CKEditor’s content filtering functionality by going to Add-Ons > Modules > Wygwam > [your config name], and changing the “Restrict allowed HTML?” setting to “No”.

That’s a new setting as of Wygwam 3.1, so you may have to update Wygwam first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.