1

I just recently updated my DV server (media temple) to their new infrastructure DV4.0. Most recently I've been experiencing latency of more than 8s to load my site or any site on my server. After further investigation, I identified an excessive RAM usage on my server which was causing absurd latency and my site(s) to time out at load time. It turns out that the new media temple infrastructure comes with NGINX running and installed instead of Apache. Here it is what the error log shows:

http://pastebin.com/iZ5yizGg

http://pastebin.com/PzSsYKNS

The problem, in my mediocre understanding, is that EE doesn't like NGINX so I'm not sure what to do at this point. I have the option to install apache or to try to configure NGINX. NGINX seems to be very performant when it comes to heavy traffic. I'm wondering if anyone here has run into this issue and what the possible solution is.

Thanks,

Juliano

| improve this question | | | | |
  • This looks like it could be an issue with PHP in general rather than EE in specific. Does a simple 'hello world' PHP script do any better? – Scott Hepler Aug 28 '13 at 10:34
  • I've been using NGINX on my last three EECMS projects, two of them on MediaTemple, and its performance is really good. This isn't a EECMS issue. – Robson Sobral Aug 28 '13 at 13:59
  • It looks like MySQL is responsible for hogging all resources. pastebin.com/XvUbmm4x – jmdesigner81 Aug 28 '13 at 14:03
  • @ScottHepler I'm going to try a simple script but it looks like the issue is with mysql. pastebin.com/XvUbmm4x – jmdesigner81 Aug 28 '13 at 14:05
  • a fine decision! – Scott Hepler Aug 28 '13 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.