1

I recently updated a site to EE v2.7 and also updated all of my third-party add-ons to the most recent versions. The site in question has several channels, and everything seems to be working fine until I try and publish/edit something in a channel that doesn't have a "Matrix" fieldtype associated with it.

Little to none of the JS seems to be working on the publish/edit form (e.g., the "Entry Date" calendar widget), and even odder, the contents of EE's file upload modal appear at the bottom of the screen -- even though the channel in question doesn't have a "File" fieldtype.

I've tried reinstalling Matrix files, clearing caches -- the usual thing. Any ideas?

  • Hey Jason, does the error reveal where it’s coming from? (class and/or filename and maybe a line number?) – Brandon Kelly Sep 3 '13 at 15:28
  • There are line numbers, but they're different depending on the channel I'm looking at. – Jason Morehead Sep 3 '13 at 21:22
  • Disregard the above comment (posted it before I was done). There's a reference to third party scripts found in the <head> tag which occurs on other channels, even those with "Matrix" fields. Then there's this bit in red: "Uncaught ReferenceError: Matrix is not defined". There's also mention of "vzUrl.init" and "(anonymous function)". Also, several errors in "jquery.js" on lines 43 ("s"), 44 ("n.fireWith"), 33 ("b.extend.ready"), and 42 ("m.addEventListener.D"). – Jason Morehead Sep 3 '13 at 21:29
1

I did some more digging, and it looks like this might not be a Matrix issue at all, but rather, an issue with the VZ URL fieldtype. On a whim, I went to one of the channels that was rendering fine, and added a URL field. Suddenly, I got the issue. I removed the URL field, and everything went back to normal.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.