2

I'm trying to update to 2.7.0 from 2.6.1.

I've done this on one website we have, but the other just isn't playing...

I'm doing the exact same thing (And also tried this 3 times and still getting the same issue) It gets to the point where I agree to the terms & conditions, then goes to this URL:

http://website.com/admin.php?C=wizard&M=do_update&language=english&ajax_progress=yes

And displays a Google Chrome error:

Server error

I normally see these errors when there is a missing DB file, or an error with the DB. But I've restored it back, ensured the CMS worked, then tried again and it still doesn't do it.

Console isn't showing anything neither.

What could be causing this?


Edit (After Disabling JS)

http://website.com/admin.php?C=wizard&M=do_update&language=english


Edit (PHP Error)

[04-Sep-2013 12:13:21 Europe/Dublin] PHP Fatal error: Class PT_Fieldtype contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (EE_Fieldtype::display_field) in /Users/shape2/repositories/website.com/system/expressionengine/third_party/pt_field_pack/pt_fieldtype.php on line 148

  • this was an error that seemed to be around a while back. IIRC the fix then was to disable JS and try it that way. I think Firefox handled it better than Chrome did. – Steven Grant Sep 4 '13 at 11:43
  • @StevenGrant Disable JS in the browser? – Jason Mayo Sep 4 '13 at 12:05
  • @StevenGrant Just disabled JS and it results with a new URL (In original question) – Jason Mayo Sep 4 '13 at 12:58
  • yeah, did you try it in Firefox? – Steven Grant Sep 4 '13 at 14:49
  • 1
    @Anna_MediaGirl Yeah - I placed the "third_party" add-ons in after the update and this worked. I also tried removing field pack and that worked also. Would this cause any problems? I've found most of the add-ons i'm using have got updates for 2.7.0 so I'm safe :) – Jason Mayo Sep 12 '13 at 9:26
1

I was having this same error going from 2.6.1 to 2.7.0. Here's how I got around it.

Don't upload your system -> third party folders until after you run the installer.

I followed all the steps here: http://ellislab.com/expressionengine/user-guide/installation/update.html except for uploading the add-ons to third party at the end of #3, ran the update and everything was fine. Then afterwards I uploaded the add-ons and everything was still okay.

It looks like conflict for you is on the add-on with the folder 'pt_field_pack'. For me it was a plugin called Safecracker Registration. You could optionally just take out the 'pt_field_pack' folder before running the install too.

Also, if afterwards in case you get an error in your control panel that says 'Your ExpressionEngine installation’s version (2.6.1) is not consistent with the reported version (2.7.0). Please update your installation of ExpressionEngine again.' refer to this thread: http://ellislab.com/forums/viewthread/237540/ and open system/installer/updates/ud_270.php and ADD this code ABOVE line 1050:

    if (empty($data))
{
    return;
}
| improve this answer | |
  • 1
    Not sure why this got down voted... Because it worked and so do all the add-ons even when I place them in the 'third_party' folder - After the update. Thanks! :) – Jason Mayo Sep 12 '13 at 9:24
0

[04-Sep-2013 12:13:21 Europe/Dublin] PHP Fatal error: Class PT_Fieldtype contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (EE_Fieldtype::display_field) in /Users/shape2/repositories/website.com/system/expressionengine/third_party/pt_field_pack/pt_fieldtype.php on line 148

Have you updated "pt field pack" with new "Field Pack" as well?

http://devot-ee.com/add-ons/field-pack

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.