1

I have a site which was on a different domain. We changed it ages ago.

I am now adding a Safecracker form, and when I click submit, it goes to the OLD domain, and ignores the return parameter I add.

I have searched all files in the website for the old domain, and searched the database, there is no reference to this old domain. I have cleared my browser cache, and EE cache. Still the same.

Somewhere, this old domain is referenced and Safecracker is using it. Does anyone have any idea?

Thanks

2 Answers 2

1

I solved it!

So our site has Membrr installed, a member subscription system. This has the facility to protect channel entries, so only members subscribed to certain subscription plans can edit channel entries. If they don't then it redirects them to a specified URL.

I discovered we had channel protection on from when we developed the site with a development URL. Even though the Safecracker form template has no Membrr tags on there, so I did not think Membrr had anything to do with it, its registered a hook for when channel entries are updated.

So I was saving this form using a new member plan I created in Membrr, that did not have permissions to add entries into this Channel (using Membrr protection), and the redirect was to an old, old dev URL, which redirected to the old URL I was searching for, which redirected to the home page. So no wonder I could not find the domain in the database or files, its an even older domain again!

So disabling channel protection in Membrr, or just allowing the subscriber to edit the channel and entering the correct domain, fixed the issue.

0

Is there any redirection going on in .htaccess?

I always use the excellent Deeploy Helper whenever I move a site, may be worth an install as it shows you anything that should have been moved: http://www.hopstudios.com/software/deeploy_helper

3
  • No htaccess redirection. Yes I used Deploy Helper for this. There is no reference to the old domain in the files or database. I do remember a long time ago finding out some setting, perhaps the domain, in the DB was encrypted but can't find the post yet, on the old Ellis lab forum (if it still exists!). Commented Sep 4, 2013 at 18:52
  • Found the post here so will try this tomorrow ellislab.com/forums/viewthread/166306/P15/#969988 Commented Sep 4, 2013 at 18:57
  • The issue in this old Ellislab post is not the issue for me Commented Sep 4, 2013 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.