0

I've seen a few posts here around this issue but none are leading me to a solution. I'm using Assets with an S3 bucket and have moved EE to a new server. The front-end of the site loads right up just fine, but all thumbs in the CMS are missing. I've tried using "Update Indexes" and it seems to complete fine but when going back to the "Assets / File Manager" screen the thumbnails are still missing.

We intentionally didn't move the cache folder over to the new server because we're trying to keep images out our Git repo.

Suggestions on how I might fix this?

1

Wanted to update the original post here with the fix.

I had to manually copy over my original cache/assets directory from the original server to the new one to solve the problem. As soon as that was in place all thumbnails reappeared in EE. I hadn't expected that anything in the cache directory should be moved between servers as it may cause conflicts.

0

I'll take a look at the code and I'll try to walk through this scenario, but as far as I can remember, when you encounter an Assets image that has no thumbnail and resides on S3, the thumbnail still should be generated.

Is the cache folder set to 777 permissions? Empty or not, it still should be there and be writable as per EE's user guide (http://ellislab.com/expressionengine/user-guide/installation/installation.html).

  • I went in and ensured that the cache directory and all subdirectories were set to 777. They weren't, so I set them to 777 and still had the issue. I then deleted the thumbs directory and went back to Assets to update the indexes. It recreated the thumbs directory but still no thumbs in EE. – Brandon Durham Sep 6 '13 at 19:33
  • Might be a good time to shoot us an email to support@pixelandtonic.com with CP and, hopefully, FTP access referencing this thread :) – Andris Sevcenko Sep 9 '13 at 6:28
  • Unfortunately this is on a very secure, very closed server, so I can't really share credentials (would love to). One interesting thing is that it's trying to load the image, and gets a status of 200 from the call for the image but nothing loads. When loading the URL up in a browser (it looks like this: qa.domain.com.com/…) I get a 200 but the screen is empty. – Brandon Durham Sep 9 '13 at 14:43
  • Brandon, can you get in touch with us over e-mail nonetheless? This might take a little back and forth and doing that here would be pretty inconvenient. – Andris Sevcenko Sep 10 '13 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.