1

Working on my first EE site (but have worked with several other CMSs) and I'm having issues with the database connection. I've pulled down files from a live site to set up a development version following the steps on the Moving ExpressionEngine to Another Server page. I've tried using the dbtest.php and can connect to the local database with no issues but when I use the same settings in the database.php file, I get a connection error. Did a little digging and the settings seem to be cached. If I do a var_dump on $this in the DB_driver.php file under if ( ! $this->conn_id) the live settings are appearing in a ar_cache_set array. I did clear the caches before downloading the live database. With a die(mysql_error()) right below that line it gives me a "not allowed to connect to this MySQL server" error. Any ideas on how to clear this? I'm not really sure where it's coming from. cache_on is set to FALSE in the database settings.

  • 1
    I have figured this out but have to wait 6 hours before I can answer it... config directory was set up as a symbolic link on the live site. – Bjorn Sep 5 '13 at 20:54
1

Sorry to hear you are having an issue. I cant think of an answer other than step 7 verify permissions.

However, once you solve it, Id recommend using master config to set up your environments. It does makes things much easier!

| improve this answer | |
0

Ah, I figured this out - nothing to do with caching. The main config directory on the live site was set up as a symbolic link with the actual config directory in the web root. That completely threw me off because it looked like there were 2 config directories in my FTP program. I was changing the one in the root and had actually downloaded and uploaded the directories in both spots instead of recreating the symbolic link.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.