2

I see this in pages where I have Safecracker forms

A PHP Error was encountered

Severity: Warning

Message: require_once(/home/dsvrtwo/public_html/system/expressionengine/third_party/safecracker/mod.safecracker.php) [function.require-once]: failed to open stream: No such file or directory

Filename: libraries/Template.php

Line Number: 1011

Any idea why it is still pointing to "safecracker"?

In the Channel Form documentation page, I don't see any opening/closing tag documentation. Am I supposed to rename my Safecracker forms?

UPDATE: I found this Channel Form examples page.

So I tried renaming my tag to {exp:channel:form}.

However, I get 2 new errors

A PHP Error was encountered
Severity: Notice
Message: Undefined property: Channel_form_lib::$EE
Filename: safecracker_registration/ext.safecracker_registration.php
Line Number: 125

A PHP Error was encountered
Severity: Notice
Message: Trying to get property of non-object
Filename: safecracker_registration/ext.safecracker_registration.php
Line Number: 125
8
  • 2
    I need to work on Safecracker Registration compatibility with 2.7. This is on my list of things to do, and just released Photo Frame 2.7 compatibility. Give me a little more time and I will get this fixed for you. Sep 6 '13 at 12:00
  • @JustinKimbrell Glad to know it was not just me messing up the upgrade steps. Thanks for the heads up! Sep 7 '13 at 1:20
  • @justinkimbrell This might be an irrelevant question but does uninstalling the old safecracker module going to affect this plugin? Sep 7 '13 at 1:46
  • Has anything been resolved with Safecracker and EE 2.7? Sep 18 '13 at 18:53
  • @Linebacker76 The issue is with Safecracker Registration, not Safecracker/Channel Forms. Sorry for the confusion. Sep 19 '13 at 0:45
1

ExpressionEngine is not pointing to safecracker, an add-on is. I hope you were upgrading on a development/testing environment. It's one of those cases where you have to wait for all your required add-ons to be compatible with the new version of EE before upgrading.

1

When you upgrade EE, installer automatically changes your all templates, but it only changes the templates in database. If you use templates in files, you have to change manually all your templates and replace {safecracker} tags with new {exp:channel:form} tags. Actually you can open the template in control panel, and copy/paste the automatically updated code to the template in file. It took my one night and few more grey hairs :) Hope this helps.

0

I had the exact issue asked by arvinsim , my form templates would not parse at all after my upgrade from 2.5.5 to 2.7 (and php error was the same). I only needed to replace {exp:safecracker} with {exp:channel:form}.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.