3
  • Assets is the only thirdparty module/filedtype installed.
  • Native cache folder are 777.
  • File upload directory is working and uploads images correctly.
  • Assets shows no folder at all. But if I upload one image AFTER installing Assets the folder shows up.
  • When trying to upload one image to the visible folder I get error message as follows: "Could not upload the file - server returned an unexpected response. Please check the server settings."
  • The status bar shows full process is done but there is no images.
  • When trying to update the button goes "blank" and no result is shown.
  • Assets now has created two cache folders in "cache > assets tmp_storage" and they are both 777. But no images ...

... ANYONE?

Versions

  • Assets 2.1.4
  • EE 2.7.0
  • PHP Version 5.3.10-1ubuntu3.8
  • 1
    After installing Assets, did you run the Index update process? There's a button called "update indexes" on the top right when in Assets. – Andris Sevcenko Sep 9 '13 at 6:27
  • 1
    Also, check your .htaccess file. Sometimes this can be an issue if you are removing index.php. Does the native file upload work to that directory? – T2theC Sep 9 '13 at 20:27
  • What is the solution if this is a .htaccess issue? I'm able to upload via the native File Manager, but see "Could not upload the file - server returned an unexpected response. Please check the server settings." when I use Assets. If I refresh the page, the file is in fact there. – Mark J. Reeves Oct 15 '13 at 15:15
  • I'm having exactly the same issue here with Expression Engine 2.7.2 and Assets 2.4.1 – Robbie Post Oct 25 '13 at 13:09
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – Jeremy Gimbel Oct 25 '13 at 13:58
1

Update your version of Assets to at least 2.2 as there was a fix for this per the changelog: http://docs.pixelandtonic.com/assets/changelog.html

| improve this answer | |
1

I just had this exact problem.

I added 777 to:

system > expressionengine > cache > assets

and

system > expressionengine > cache > assets > thumbs

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.