I am running EE2.6.1 and want to upgrade my Playa addon from version to 4.4.5.

I was running into the same errors as posted previously here, then reverted back to the previous Playa version and tried again.

This worked locally, but not on my production install.

I followed the upgrade instructions by replacing both folders and going through Add-Ons > Fieldtypes > Playa to run the upgrade script.

When I examined the database through phpMyAdmin, I could not find any column parent_is_draft in either database - local or production. However, the local EE install shows "4.4.5" in Add-Ons > Fieldtypes > Playa, while the production install shows the old version.

For the time being I've rolled back to the old version. What steps can I try next?

Thank you!

Edit: Just like reported here I see different versions: When going to Add-Ons > Modules > Playa, EE shows "4.4.5".

2 Answers 2


After updating Playa and it failing to run it's DB schema, here's what you can try: Take a look at the columns in exp_playa_relationships table in the database.

  • Does it have a field parent_var_id? If no, then the version you should set is 4.1.
  • If yes, does it have a field parent_is_draft? If no, then the version you should set is 4.3
  • If yes, then the version you should set is 4.4.5

Now, set the version number we determined in the previous three steps for the Playa field in the exp_fieldtypes table and go visit the Add-ons -> Fieldtypes -> Playa page and hit submit.

Everything should be all working now.

  • I did as you suggested, but when going to Add-ons > Modules, Playa is still listed with version 4.4.5.
    – user2042
    Commented Sep 14, 2013 at 5:20
  • Any ideas though how to resolve the original problem with my live site? I'd like to update to 4.4.5, but it keeps on failing. Thank you.
    – user2042
    Commented Sep 14, 2013 at 5:21
  • When you say that Playa is listed with version 4.4.5 - isn't that the version you're updating to? Commented Sep 16, 2013 at 5:41
  • The update to 4.4.5 fails, hence my post. When downgrading to 4.1 the module entry keeps saying "4.4.5" for the version.
    – user2042
    Commented Sep 17, 2013 at 6:04
  • Module entry is always going to show you whatever is set exp_modules table - EE does not really provide a mechanism for downgrading.. If you want to update to 4.4.5 then upload the appropriate files and if docs.pixelandtonic.com/playa/installation.html fails ,then follow the procedure above. If you want to downgrade, then upload the appropriate files and you'll have to manually change the version number in DB and delete two columns (parent_var_id and parent_is_draft) from exp_playa_relationships. Not sure why you'd want that, though :) Commented Sep 17, 2013 at 7:55

This finally worked for me:

  • Tools > Data > SQL manager
  • Database Query Form
  • enter queries:
ALTER TABLE exp_playa_relationships ADD parent_var_id INT(6) UNSIGNED AFTER parent_row_id, ADD INDEX (parent_var_id) 

ALTER TABLE exp_playa_relationships ADD parent_is_draft INT(1) UNSIGNED NOT NULL DEFAULT 0 AFTER parent_var_id
  • Submit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.