7

I am moving my expression engine site and database to a new server. Everything seems to be directed correctly but when I access admin.php I get a blank page. Any thoughts?

  • 1
    Open index.php file at root and change the $debug = 0; with $debug = 1;. Now see if you are seeing any error message instead of white screen. – Bhashkar Yadav Sep 13 '13 at 1:32
  • I agree with the above suggestion. I also have an article covering some additional suggestions in troubleshooting EE. They might be helpful: focuslabllc.com/blog/troubleshooting-expressionengine – Erik Reagan Sep 13 '13 at 8:20
6

If you are seeing a white screen there's an error happening and you need to display that error to be able to know how to proceed. (See the EE user guide about Blank Pages.)

To show that error, edit your folder's index.php file and replace $debug = 0 with $debug = 1. Revisit your site and you should see the error.

If you see something like this:

A Database Error Occurred
Unable to connect to your database server using the provided settings.

Then follow this answer on another question.

If that doesn't help, try the solutions offered in this answer.

1

I had this problem recently after the host upgraded to PHP 5.3.27. The front of the site worked fine but when I tried to log in to the CP (after logging in) I got the white screen of death. Are you able to log in at all?

My problem was that the new version of PHP had been compiled, quite correcty, with an oAuth plugin. This caused a problem with an old Twitter add-on that used an old oAuth PHP library.

The solution was as simple as commenting out one method in the add-on (the method didn't even do anything) and it was all fixed. Took 8 hours to work that out.

So, do you have anything that might be using an old oAuth library?

I should add that no matter what I did I could not get ANY debug info to display.

  • 1
    /system/index.php also has the "debug='1' " setting. If you are trying to debug something in the cp or an addon that uses ACT turn that one on as well. – Solspace Sep 13 '13 at 22:53
  • I ran into this same trouble with v1.0.2 of NSM Twitter, but it was patched in version 1.0.4. Updating the add-on resolved the issue for me. – Adam Christianson Dec 11 '13 at 14:54
0

My experience with blank home page.

Sometimes when you are migrating your page you can get blank home page.

I found the problem with the home page not displaying from the base URL. it was because there was a default.html file in the root directory. The old hosting server must had set the order to look for start files to PHP extension as the first default so it ignored the default.html file in the root directory and loaded index.php.

The new hosting server must have the default extension it looks for as an .HTM or .HTML file and was loading the blank default.html file first. Once I deleted the blank default.html file the hosting server started loading the index.php file and displayed the WordPress home page.

BR
Andrej

0

The new hosting server must have the default extension it looks for as an .HTM or .HTML file and was loading the blank default.html file first.

  • Can you clean up your answer, please? – jrothafer Jul 6 '15 at 12:22
0

Also, try the site without any .htaccess files. If the server (apache) is bawking trying to read these (because the apache version/config is different on the new server) the bad .htaccess can casue a WSOD.

0

Most probably it's a server side issue or a .httaccess. As specified above try change in your config.php file $debug = 0 with $debug = 1

0

Check the PHP version. The 5.2 and below causing this issue. Also as was mentioned above run debug mode. I had same issue after moving the website to another host, where you should manually set the php version

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.