0

When I copy content of article (from other site) and paste it to my field (field type: wygwam), all styles is removed, only plain text remains. I need my article is the same to the article that I copy from other site. May somebody helps me?

Thanks!

0

By default you need to use paste from Word icon in the toolbar, not the keyboard shortcut Ctrl+V (or Cmd+V).

You can also edit the toolbar configuration within Wygwam and add an advanced setting for "forcePasteAsPlainText" and set it to No. You can then use Ctrl+V (or Cmd+V) and your formatting is retained.

But this will mean that if a user copies from another source, it could contain all the other junk (e.g. copied from Word).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.