1

I have a simple safecracker form to allow a member group change the status of an entry

{exp:safecracker 
channel="{channel_name}" 
return="/template/" 
author_only="no" 
include_jquery="no" 
safecracker_head="no" 
datepicker="no"
use_live_url="no"
entry_id="{segment_3}"
id="apply_status"}
     {status_menu}
    <select name="status" tabindex="1">
        {select_options}
    </select>
{/status_menu}  
<input type="submit" name="submit" value="Submit" tabindex="2" id="apply_status">
{/exp:safecracker}

This was working fine until I upgraded to ee2.6.1. The issue is if the Entry author is in a different member_group than the editor member_group I am given the "you are not authorised to perform this action" error.

The editor member_group has permission to: Post and edit entries in the channel Can edit entries authored by others

I thought the problem might be related to this bug in2.6 https://support.ellislab.com/bugs/detail/19335 But that seems to be corrected in 2.6.1

Super-Admins do not get this error.

Can anyone replicated this error or is there a setting I'm missing somewhere?

  • 1
    Are you using a custom statuses, and if so, has the member group in question been granted access to those statuses? – Derek Hogue Sep 18 '13 at 18:42
  • Yes I am using Custom Statuses and the member group has been granted access to them through Admin > Channel Admin > Statuses > Custom Group Name > Custom Status Name – Micky Kelleher Sep 19 '13 at 9:05
  • Did you have any luck with this, i have a feeling we are getting the same problem... – Jamesaa Sep 30 '13 at 13:38
  • No I'm afraid not. I'll have to send a bug report. Been dragged away on another job for the moment. – Micky Kelleher Oct 2 '13 at 8:13
3

Bug fix mentioned here

http://support.ellislab.com/bugs/detail/20084

Please make sure these seemingly unrelated settings are set:

The original author’s group has to have “Include Members in PUBLISH page multi-author list?” set to “Yes”

The person attempting to make the edit must have “Can change the author name when > posting channel entries” set to “Yes”

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.