1

I have a list of Solspace Calendar events that I would like to paginate. According to the documentation, the pagination parameter and variable pair should work the same as channel:entries. I am able to limit the events to 10 with the limit="" parameter, but the {paginate} variable pair does not display the pagination links.

{exp:calendar:events calendar_name="Events" limit="10" date_range_start="" orderby="event_start_date" sort="ascending"}
            <div>
                <h4><a href="{page_url}">{title}</a></h4>
                <h5>{event_start_date format="%j %F %Y :: %g:%i%a"}&ndash;{event_end_date format="%g:%i%a"} 
                <p>{event_location}</p>
                </h5>
            </div>
            <hr />
            {paginate}Page {current_page} of {total_pages} pages &nbsp; {pagination_links}{/paginate} 
{/exp:calendar:events}
  • To eliminate the obvious set the limit really low, say to "2" -- that way you can be certain it's not an issue of not having enough results to paginate. Does pagination output still not show after trying that? – Alex Kendrick Sep 18 '13 at 13:59
  • @AlexKendrick I've adjusted the limit to 2 but still no pagination output. – jmulkey Sep 18 '13 at 14:42
3

Instead of limit="10", try using event_limit="10". From the {exp:calendar:events} documentation:

http://www.solspace.com/docs/calendar/events/#event_limit

| improve this answer | |
  • I replaced the limit parameter with event_limit. Still no pagination... – jmulkey Oct 4 '13 at 12:34
  • 1
    Are you sure you have more than 10 events on "today"? If you keep date_range_start="" empty or don't use it, Calendar defaults to "today". Same for date_range_end="". Make sure you have more events to display than the value in the limit="" parameter. – Solspace Oct 7 '13 at 20:22
  • Thanks! I removed the date range parameter and updated to the latest calendar version. Pagination is working! – jmulkey Oct 15 '13 at 13:10
2

You are missing the paginate parameter on your opening calendar:events tag. Try adding paginate="bottom" and see if that fixes your issue.

| improve this answer | |
  • That is obviously an error in my code and I was almost certain that this would fix the problem, but I just added the parameter and there's still no pagination. – jmulkey Sep 19 '13 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.