1

We've been developing a mayor update for one of our clients website. Their current website runs EE 2.5. We've made the change to 2.7 for several obvious reasons. And everything worked beautifully on the development server.

Then I noticed that the client hosting is running PHP 5.1. Which is sufficient for EE 2.5. But not for 2.7. Php should be version 5.2.4 or higher. Also, the php upgrade isn't possible without a linux upgrade, so said the hosting company. And that can't be done before the deadline next week.

So my question is, what are the implications of running EE 2.7 on php 5.1?

4

It won't work at all. EE 2.7 (and most add-ons built for it) use features only available in PHP 5.2+, probably most notable is json_encode which EE uses a lot internally. Some add-ons such as Store 2 even require PHP 5.3 as minimum now.

Personally I would ditch the host and find one who takes software updates (and therefore server security) more seriously. PHP is up to version 5.5 now and there is no excuse for running software which was released in 2005.

| improve this answer | |
  • I've tried it locally. Finding a usable version of php 5.1 wasn't that easy. But I found one. And I've managed to find workarounds for the json_encode and json_decode. The biggest issue is the difference in the date/time functions. There are some experimental Pear classes. But I'm not sure that's the way to go. Problems will probably arise anyway. – Diederik Sep 19 '13 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.