1

I'm a newbie to Backup Pro / Backup Pro(ish), and also to Cron jobs, and was hoping someone could help as this is happening on every site I've tried to set up.

I have Backup Pro(ish) installed on a site now (I'm hosting with A Small Orange). If I go and click on the Backup Database tab, everything works great and a backup is created in the correct folder (above root). If I use the URL given to me under the "Cron Commands", it will create a backup. However, my Cron jobs are not creating backups. To create the Cron job, I went in and selected the frequency to create them, then pasted the full command (wget ?ACT=xx&type=db) into the command line.

It runs, as I get an email. Here is the message that I get (IP and correct URL are removed)

--2013-09-20 12:00:01--  <MYSITE>?ACT=xx Resolving <MYSITE>... xxx.xxx.xx.xxx Connecting to <MYSITE>|xxx.xxx.xx.xxx|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 0 [text/html]
Saving to: `index.html?ACT=xx.5'

     0K                                                        0.00 =0s

2013-09-20 12:00:02 (0.00 B/s) - `index.html?ACT=xx.5' saved [0/0]

Any other suggestions on what to look at?

Thanks in advance!

4

I'm the developer behind Backup Pro(ish) so I may be able to help here.

First, the email you're receiving is from your systems Cron mechanism and not Backup Pro(ish). I can tell that just from the content of the email (BPs email is completely different). Really, I have zero control over that email; you'll have to contact your host to modify the setup on that if you're unable.

Now, when you run a wget command, which the basic Backup Pro(ish) Cron command uses, on some systems it'll save the output to the server unless instructed otherwise. One of the more irritating things about the wget program is that there's no standard installation or base configuration that's across all platforms. So, for example, on my systems, the command in Backup Pro(ish) doesn't save the output nor send an email. On yours, it does apparently. Your host should be able to help you with disabling wget file output when it runs.

Lastly, as to why it's not running, I'm just as confused as you are on that. But, with you confirming that pasting the Cron URL into your browser executes the backup successfully I'm confident the issue lies in your network.

One cause for this would be if your server doesn't know your site URL exists on the physical server then it doesn't know where to send the request. Weird, I know, but when you're setting up a server it's rarely a given that the server your site lives on knows it does outside of Apache (DNS would have to be configured on it). I've seen this many, many, many, many, many times in fact. A simple update to your server's host entry (as you would do in Windows or OSX) to tell your OS that your URL lives on itself should sort you out. Your host should be able to help there.

|improve this answer|||||
1

I haven't used this addon before but I see index.html in the email... shouldn't this be index.php to hit EE?

|improve this answer|||||
  • Act number should be whole number too – Lloyd Hill Sep 21 '13 at 9:03
  • I had just copied the link provided in the Backup Pro(ish) CP. I did go back and add index.php to the link in the Cron job, but that didn't do anything either. I'll contact my host and see if they have suggestions. – Todd Sep 23 '13 at 16:22
1

OK, sorry for the delay in getting back to this, but I wanted to be sure things were working - and they are. In talking with the host, and running several tests, they had me switch from wget to curl, and I am now getting regular backups. Thanks to all for their responses and suggestions - and thank you, Eric, for a wonderful add-on!

|improve this answer|||||
  • What does your CRON command look like now? MediaTemple doesn't run wget on GS. Perhaps curl will. – Stuart McCoy Oct 11 '14 at 22:01
  • My host told me to use this: curl 'yoursite.com/?ACT=73&type=db' – Todd Oct 13 '14 at 16:32
  • Thanks. I'll give it a shot next time I have an EE site I'm setting up on MT. – Stuart McCoy Oct 13 '14 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.