1

Freeform 4.1.2 EE 2.7 - I have my forms setup and when I submit the forms not submitting, not being redirected to the redirect template no notifications. Basically nothing is working. After I press submit it just redirects to the home page www.domain?ACT=70

{exp:freeform:form
    form_name="contact"
    return="Contact/thank_you"
form_id="1"
notify_admin="yes"
admin_notify="[email protected]"
admin_notification_template="contact" 
required="email" 
require_captcha="yes" 
}
    <dl>
    {freeform:all_form_fields}
        <dt><label>{freeform:field_label}</label></dt>
        <dd>{freeform:field_output}</dd>
    {/freeform:all_form_fields}
    </dl>
    {if freeform:captcha}
        <p>Please enter the word you see in the image below:</p>
        <p>{freeform:captcha}<br />
        <input type="text" name="captcha" style="width:140px;" /></p>
    {/if}
    <p>{freeform:submit}</p>
    {if freeform:no_results}
        <p>
            Specified form was not found. Please make sure you have
            specified the correct short name of the form in the
            <b>form_name</b> parameter.
        </p>
    {/if}
{/exp:freeform:form}

1 Answer 1

3

fond the issue, when using an index.html file as a site offline page causes the form to now work.

Removing the index.html and making the site live with the index.php file allowed the form to work

1
  • Ran into this on a site I inherited and as soon as I removed index.php the forms started working. Good find. You should accept your won answer.
    – CreateSean
    Dec 11, 2013 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.