2

I try to import a ee db into my local environement and I get this Error:

SQL-Befehl:

-- --------------------------------------------------------

-- Tabellenstruktur für Tabelle exp_accessories -- CREATE TABLE exp_accessories (

accessory_id INT( 10 ) UNSIGNED NOT NULL AUTO_INCREMENT , class VARCHAR( 75 ) NOT NULL DEFAULT '', member_groups VARCHAR( 50 ) NOT NULL DEFAULT 'all', controllers TEXT, accessory_version VARCHAR( 12 ) NOT NULL , PRIMARY KEY ( accessory_id ) ) ENGINE = MYISAM DEFAULT CHARSET = utf8 AUTO_INCREMENT =8;

MySQL meldet:

1050 - Table 'exp_accessories' already exists

I have absolutely no clue about db files what do I have to do?

1

Okay I found the error. The new db didn't have the same name as the old one so I deleted the lines:

CREATE DATABASE IF NOT EXISTS `db_name` DEFAULT CHARACTER SET
latin1 COLLATE latin1_swedish_ci; USE `db_name`;

Now it works. But that's not what the error said. Is it possible to disable this line directli in the export window of phpMysql?

  • How are you exporting the database? – Anna_MediaGirl Sep 25 '13 at 15:46
  • I just go to phpmyadmin and choose export. There I choose "Save as file" and thats it. – KSPR Oct 13 '13 at 11:06
0

Looks like this is possibly a bug in your phpmyadmin version: http://sourceforge.net/p/phpmyadmin/bugs/4019/.

The create database code shouldn't be added with the default export.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.