1

Importer 2.2.2 seems to have installed correctly on EE 2.7, then receiving the below error when entering setup for the Module. Any thoughts on why the error is being thrown and how to fix it?

Fatal error: Uncaught exception 'Exception' with message 'DateTimeZone::__construct(): Unknown or bad timezone ()' in D:\Inetpub\CBLink1\system\expressionengine\third_party\importer\addon_builder\addon_builder.php:4097 Stack trace: #0 D:\Inetpub\CBLink1\system\expressionengine\third_party\importer\addon_builder\addon_builder.php(4097): DateTimeZone->__construct('') #1 D:\Inetpub\CBLink1\system\expressionengine\third_party\importer\act.importer.php(65): Addon_builder_importer->timezone_offset() #2 D:\Inetpub\CBLink1\system\expressionengine\third_party\importer\addon_builder\addon_builder.php(702): Importer_actions->__construct() #3 D:\Inetpub\CBLink1\system\expressionengine\third_party\importer\mcp.importer.php(139): Addon_builder_importer->actions() #4 D:\Inetpub\CBLink1\system\expressionengine\controllers\cp\addons_modules.php(357): Importer_mcp->index() #5 [internal function]: Addons_modules->show_module_cp() #6 D:\Inetpub\CBLink1\system\codeigniter\system\core\CodeIgniter.php(319): call_user_func_array(Array, Array) #7 in D:\Inetpub\CBLink1\system\expressionengine\third_party\importer\addon_builder\addon_builder.php on line 4097

1

The latest version of Importer, as of this writing, is 2.2.3. This version adds EE 2.7 compatibility. Please upgrade to this version and let us know if the issue persists.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.