1

I've just upgraded a site from EE 2.1 to EE 2.7.1 and got it basically working by upgrading the associated AddOns. Playa is still having trouble (migrated from 3.1 to the latest 4.4.5).

Simple Playa code that should return the entry_ids for the items selected within the page_sidebar_content field are instead returning a text string.

So,

 {page_sidebar_content backspace="1"}{entry_id}|{/page_sidebar_content}

is returning something like:

 M140o93H7pQ09L8X1t49cHY01Z5j4TT91fGfr

instead of something like

114|32|61

Any ideas?

  • Putting the code into an embed file works, but still not sure why that is necessary. – Te3d Oct 2 '13 at 18:05
  • In what context are you using the Playa variable pair? This is definitely a parse order issue. If you update your question with more context surrounding the variable pair, it may be easier for someone to help suggest some changes to resolve the issue. – Jeremy Gimbel Oct 4 '13 at 0:04
  • Any chance you're using Stash? – unexplainedBacn Oct 8 '13 at 13:53
1

Playa has an update script that you might have to trigger. Try Add-OnsFieldtypesPlaya to trigger Playa’s update script and see if that sorts things out.

| improve this answer | |
  • Had tried that too and checked the database to make sure the correct fields are included ('parent_var_id' and 'parent_is_draft') and they are. – Te3d Oct 2 '13 at 20:44
0

Try the child_ids tag.

{page_sidebar_content:child_ids}
| improve this answer | |
  • Already did. Same result. – Te3d Oct 2 '13 at 17:26
0

I ended up figuring out that it was a conflict with the now deprecated Twitter Timeline Add-On. Once that old code was removed from the site, all worked as it should.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.