4

upgraded a site from 2.1.3 to 2.5.3 and once the upgrade successfully completed I tried to access the CP and get a blank page.

I checked .htaccess and found an old method for removing index.php

RewriteEngine on
RewriteCond $1 !^(favicon\.ico|info\.php|index\.php|path\.php|php\.ini) [NC]
# Exclude EE folders
RewriteCond $1 !^(system|images|img|fr|themes|media)/ [NC]
# Exclude 3rd party folders
RewriteCond $1 !^(css|js|uploads|ca_en|ca_fr)/ [NC]
# Remove index.php
RewriteRule ^(.*)$ /index.php/$1 [L]

which I commented out and replaced with the official method - no change. The front end of the site loads fine, but I can't get into the backend. Any ideas?

  • 1
    A blank page nearly always means there is a fatal error happening somewhere. Can you check your CodeIgniter and/or Apache error logs? – Phil Sturgeon Dec 11 '12 at 17:35
8

I usually document this stuff on my own (for the next time) so I'm racking my brain trying to remember. However, I think for me, there was an add-on (probably accessory) that wasn't compatible, and it blanked the whole thing out. I ended up disabling until it started working. You might just update all of your stuff to see if that helps.

  • 1
    Agree with Todd, for me it is often an extension. – Christy Collins Dec 11 '12 at 16:26
  • I think Todd's on to something. A library some of the fieldtype add-ons use was moved in 2.4 Matrix, Playa, Assets, Solspace Calendar, Google MX ad-ons were all affected. What's the best way to disable add-ons with no CP access? Delete from the exp_modules table? – Patrick Pohler Dec 11 '12 at 16:26
  • 1
    With Todd's answer in mind, see this comprehensive answer on white screen of death. The question was very similar. – Alex Kendrick Dec 11 '12 at 16:28
2

Check the settings in the database and config files for the path to the themes directory. That used to get me all the time.

  • can't find it in the database. themes path not in config.php trying to find global config overrides in docs, but search is broken. – CreateSean Dec 11 '12 at 15:04
  • found the config overrides and set them, no change. – CreateSean Dec 11 '12 at 15:11
2

Is the system path in admin.php different from index.php? Another option is to set PHP error reporting on admin.php and see if you catch any exceptions

error_reporting(E_ALL);
  • path is the same. added that line no change. page is blank. – CreateSean Dec 11 '12 at 15:03
2

Okay,

So I also submitted an urgent ticket with EllisLab and found the issue after Dan Decker inspected. It turns out it was a legacy 3rd party module causing the problem. NDG Flexible Admin was installed, however you can't upgrade this without access to the CP since the name has now changed to Zoo Flexible Admin. The key was to go into phpmyadmin and delete all tables with ndg in them. Once I did this I could access the CP again.

Now I have to re-create the menus I had before, but that shouldn't be too much trouble as I have a backup site I can look at. The key here is if you are upgrading an old site running ndg flexible admin, upgrade that addon before upgrading EE.

  • I hate it when it's an add-on issue. Once you found out what it was, could you not just remove the acc, ext, mod entries and left the ndg tables? Maybe could have ported or pulled your menus that way. ;) – W3bGuy Dec 12 '12 at 5:44
  • Brian, possibly but the menus where pretty simple and I had a backup of the site so i could use that to remind me of what was set up. – CreateSean Dec 12 '12 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.