2

When trying to upgrace 2.5 to 2.7 I get this error:

Fatal error: Cannot redeclare class Installer_Extensions in /home/user/admin/expressionengine/cache/updater/1381156626_439122/system/installer/libraries/Extensions.php on line 31

Then when I try and view the site I get a white screen with this error:

Error Number: 1054

Unknown column 'hash' in 'field list'

    SELECT `hash`, `timestamp` FROM (`exp_developer_log`) ORDER BY `timestamp` asc

    Filename: libraries/Logger.php

    Line Number: 106
1

Possibly the old version didn't have hash column in the table, and v2.7.1 does...? I've not got a v2.7.1 to compare.

Did you clear cache before updating? Had you done a previous update on this build before? Clear all the files from the cache folder manually then try the installer again. /home/user/admin/expressionengine/cache

When you copied the new files up to the server - did you delete the old folders and files first? Sometimes I get issues with FTP if I've not deleted the folder first, as in old files my remain, or not be updated correctly, so ensure you've not got a mix of old files and new - especially libraries/Logger.php.

Just compared v2.6.1 with v2.7.0 and the hash column has appeared in the exp_developer_log table - although there's no reference of it in the change log.

| improve this answer | |
  • I was using DevDemon's Updater. I tried 2.7.0 and 2,7,1 and got the same errors both times. Tried to clear the cache and update again and got the same errors. I think I have to roll back to yesterdays' backup and start over. I may not use DevDemon's updater and try the manual upgrade – Peter Eastwood Oct 7 '13 at 16:13
  • Check the permissions on your folders - especially your cache folder. Possibly Devdemon Updater couldn't update or clear the cache folder because it couldn't overwrite existing files...? Have you contacted their support, I'd expect they'd respond promptly. – Peter Lewis Oct 7 '13 at 16:28
  • that could be it. It looks like the cache folder is only set at 755. I did contact them and still waiting for a reply. Funny thing is the permissions settings all passed in the module – Peter Eastwood Oct 7 '13 at 16:43
  • could I just delete the row in the developer log?A third-party add-on is calling $this->load->library('security'), which is deprecated as the CI_Security class has been moved to Core, so it is always loaded. – Peter Eastwood Oct 7 '13 at 18:13
  • I added the required column hash in phpmyadmin and I was able to get rid of the error. Now my admin shows 2.7.1 but it really isn't the install stopped at 2.6.1 – Peter Eastwood Oct 7 '13 at 18:37
3

I added the required column hash in phpmyadmin and I was able to get rid of the error.

then I did a manual upgrade because Devdemon updater failed at ver 2.6.1

| improve this answer | |
  • Hey, Peter! Open the installation files and look for this column to make sure you set it right. – Robson Sobral Oct 7 '13 at 19:32
  • where would I be looking? – Peter Eastwood Oct 7 '13 at 19:41
  • 1
    There is on file for every version update on \system\installer\updates. Open the files from 2.5.1 to 2.7.1 e search for "hash". You'll find it at the line 945 of the file ud_270.php. – Robson Sobral Oct 7 '13 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.