0

I have an MSM installation with two sites (EE version 2.5.5, Playa version 4.4.5). I am using Playa on Site 2. When I am logged into the CP from the URL of Site 2 (i.e. http://site2.com/admin.php), my live filters for Playa fields work as expected. However, when I am logged into the CP from Site 1's URL (i.e. http://site1.com/admin.php) and am working in the Site 2, the Playa fields don't filter properly.

Here's what I'm doing: from the channel entry form, in my Playa field, I click the plus button on the Droppanes search menu to filter by Category. However, as soon as I choose the "Category" filter option (or any other filter option), all my listed entries are grayed out, and the filter doesn't seem to limit the entries.

I read on this question (Playa Filters failing with Force SSL module in place) that filters work with an AJAX call based on your URL. I also read that you can direct Playa to the proper site index using this line in the config:

$config['playa_site_index'] = "https://example.com/index.php";

I added this line to my Site 1 config and pointed it at Site 2's URL:

$config['playa_site_index'] = "http://site2.com/index.php";

Reset my browser cache, logged back in, but still not working. Any suggestions?

  • We have an installation doing exactly this as well. – David Oct 14 '13 at 18:33
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Jeremy Gimbel Oct 14 '13 at 20:41
1

Josh,

cross-domain Ajax requests simply won't work - it's a browser security thing and there's no feasible way around it.

What you should be trying to accomplish is for each MSM CP to shoot off the requests to it's respective domain, not a single silver-bullet domain, since that will work only when accessing CP from the same domain as the config settings.

Setting $config['playa_site_index'] to "/index.php" should do the trick in this case.

| improve this answer | |
  • Ahh, that makes sense. This worked! Thanks so much. – Josh KG Oct 15 '13 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.