1

I'm having trouble uploading images using Assets.

Assets: v2.1.4
EE: v2.6.1 - Build Date: 20130506

They are uploading. If I refresh the Assets screen, I see them. But when I upload them, I receive this error:

http://circa1977.net/snap/assets-uploading-trouble.png

Note that's only the case for the Image Uploads level directory. If I select Team on the left, and upload, I have no trouble.

Here's the AJAX response:

<div style="border:1px solid #990000;padding-left:20px;margin:0 0 10px 0;">

<h4>A PHP Error was encountered</h4>

<p>Severity: Warning</p>
<p>Message:  mkdir(): No such file or directory</p>
<p>Filename: libraries/Filemanager.php</p>
<p>Line Number: 1311</p>

</div><div style="border:1px solid #990000;padding-left:20px;margin:0 0 10px 0;">

<h4>A PHP Error was encountered</h4>

<p>Severity: Warning</p>
<p>Message:  fopen(../uploads/images/_thumbs/index.html): failed to open stream: No such file or directory</p>
<p>Filename: libraries/Filemanager.php</p>
<p>Line Number: 1315</p>

</div><div style="border:1px solid #990000;padding-left:20px;margin:0 0 10px 0;">

<h4>A PHP Error was encountered</h4>

<p>Severity: Warning</p>
<p>Message:  fwrite() expects parameter 1 to be resource, boolean given</p>
<p>Filename: libraries/Filemanager.php</p>
<p>Line Number: 1316</p>

</div><div style="border:1px solid #990000;padding-left:20px;margin:0 0 10px 0;">

<h4>A PHP Error was encountered</h4>

<p>Severity: Warning</p>
<p>Message:  fclose() expects parameter 1 to be resource, boolean given</p>
<p>Filename: libraries/Filemanager.php</p>
<p>Line Number: 1317</p>

</div>{"success":true,"file_id":91,"folder_id":"2"}

I am able to upload via the native File Manager to that root directory.

I have checked permissions on the cache folder.

I have the following in config.php:

$config['assets_site_url'] = '/index.php';

$config['assets_cp_path'] = dirname(__FILE__).'/../../syncadmin/';

For server path to upload directory I have: ../uploads/images/

My system folder resides above public.

I've tried a few different solutions, including switching session from Cookies-only to Cookies + Session ID, changing permissions, changing paths, to no avail.

Any help would be greatly appreciated.

Thanks!

Mark

1

This was a bug that has been fixed in Assets 2.2. See changelog.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.