0

I’m working on a new site, using a fresh install of 2.7.2. Everything’s been going swimmingly (sort of), until now I went to edit some custom fields. When I click on a field name to do an edit, I get the following:

A Database Error Occurred Error Number: 1146 Table 'my_database_name.exp_grid_columns' doesn't exist

SELECT * FROM (exp_grid_columns) WHERE field_id IN (11) AND content_type = 'channel' ORDER BY col_order Filename: models/grid_model.php

Line Number: 631

Using phpmyadmin, I see that there is in fact no “exp_grid_columns” table in the database. So what does that mean? Should I just create a table with that name? Not actually sure what’s involved with that….

I saw a bunch of 1146 error codes relating to the Comment module in the EE Forums, but this doesn’t seem to have anything to do with that (I even tried installing the Comment module).

I’m not really a MySQL person, so I’m not sure where to go from here. Any ideas?

Thanks in advance!

  • Is the Grid fieldtype enabled? – Derek Hogue Oct 19 '13 at 1:59
1

You should have that table in your database. Here's what it should look like.

[image removed by user]

You may need to (re)install the Grid fieldtype under Add-ons > Fiedtypes. If it's already installed, uninstall it and install it again.

Update

In your database, check the exp_fieldtypes table. If you have a row for grid, delete it. Delete the new exp_grid_columns table you tried to manually add.

  • Thanks for this tip! I didn't in fact have the exp_grid_columns table in my database. However, EE shows that the grid fieldtype is installed. I went to uninstall, but it wouldn't uninstall because it couldn't find the table! So I tried adding the table (I'm not really a MySQL person...), but then when I tried uninstalling Grid fieldtype I got: A Database Error Occurred Error Number: 1146 Table 'ninemain_abdbase.exp_content_types' doesn't exist DELETE FROM exp_content_types` WHERE name = 'grid' Filename: models/grid_model.php Line Number: 129` any ideas on where to go from here? – edward Oct 25 '13 at 19:01
  • See updated answer. After that, try reinstalling Grid. – Stephen Callender Oct 25 '13 at 21:26
  • Thanks for following up! Following your directions did allow me to try to reinstall Grid, but then I got this new error message: ` A Database Error Occurred Error Number: 1146 Table 'ninemain_abdbase.exp_content_types' doesn't exist INSERT INTO exp_content_types (name) VALUES ('grid') Filename: models/grid_model.php Line Number: 102 ` It looks like my database is missing some things! Do you think it's best to just start with a clean install? This site doesn't have a lot of data in it yet because it's new... – edward Oct 25 '13 at 22:15
  • Ugh, yeah, re-download EE in case you have a corrupted file and start all over. :) – Stephen Callender Oct 25 '13 at 22:54
  • Yes, thanks for the original idea. I'm not sure where things went wrong; whether in an update to 2.7 or by not updating all my modules first.... hard to say. But I think the least time-consuming idea is just to start over. Thanks for your interest and help! – edward Oct 26 '13 at 2:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.