1

I'm using the latest builds of Calendar and EE (1.8.5 and 2.7.2 respectively) and am having problems getting the calendar to save the dates when creating or editing through Channel Form (Safecracker).

All works fine if saved in EE itself so it seems to be an issue with compatibility with Channel Form. The entry also saves without any other issues. I've tried a 'vanilla' form with only the title and the Calendar widget with no success. I wondered if you might have any suggestions for troubleshooting?

The field appears to be working fine (no javascript errors, datepicker appearing, etc) and my code is as follows (simplified)

      {exp:channel:form
           channel="channel_events"
           return="registration/listing/event_location/ENTRY_ID"
           include_jquery="no"
           include_assets="yes"
           datepicker="yes"
           error_delimiters='<p class="form_error inline_error"><span class="icon">* </span>|</p>'
           preserve_checkboxes="yes"
           id="event_form"
           error_handling="inline"   
           class="sc_form"   
         }
             <input type="text" class="i_text" name="title" id="title" value="{title}" maxlength="75"  />
             {error:title}
             {exp:calendar:date_widget}
             <input class="submit_btn" id="event_submit" type="submit" name="submit_listing" value="Save" />
         {/exp:channel:form}

I'd be grateful of ANY thoughts/suggestions you might have!

Thanks Tim

5

Having dug through the archived forums on Solspace I found this gem: http://www.solspace.com/forums/viewthread/11282/P15/

Basically it appears that adding the id="" parameter in the Channel Form/Safecracker form tag somehow breaks things. Removing that parameter seems to have fixed the issue.

Thanks to Anna for the really useful suggestions, though :)

| improve this answer | |
  • This also fixed the issue for me. I want to note that this is a bug that was reported in January of 2012, and it remains unfixed. It'd be really nice if @Solspace would provide some sort of update, even if it's unfixable. – Mark Drzycimski Dec 10 '13 at 22:15
0

Have you tried setting datepicker="yes" to datepicker="no"? Do you need the date picker enabled? Seems like Solspace would load its own JS for their date field.

| improve this answer | |
  • Thanks, Anna. Tried quite a few variations of including datepicker/whether to try including the Calendar module's own jQuery UI. Weirdly I couldn't get it working with the setup suggested on their docs (using jQuery 1.3!) but adding datepicker="yes" and including a more recent version of jQuery resolved this. I guess there could be something javascript related going wrong, but there are no js errors in firebug and the UI all seems to be working properly. – Tim Jukes Oct 23 '13 at 0:44
  • I'd suggest reuploading the Calendar theme directory to rule any issues out there. Sounds like some JS collision issues. I would report it to them directly as a potential bug. – Anna_MediaGirl Oct 23 '13 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.