3

My client has alerted me that some time in the last 2-3 months, they've lost the ability to upload files directly through WYGWAM. I've updated WYGWAM to its most recent version, and disabled any advanced settings, but I am not seeing the upload options anywhere.

enter image description here

I've asked WYGWAM to use the EE file manager, and I can succesfully upload images via the regular File Manager, but just not via WYGWAM.

Any ideas?

Edit I am running version 2.4.0 of EE, and 3.2.1 of Wygwam. I realize that 2.4 is pretty old, so I am having our systems guy update it this week.

1
  • Several questions that may lead to the answer... Is EE up-to-date? Is this a superadmin login or a different member group? Have you tried using CKFinder instead of EE file manager? When you tested the upload were you using the login the same login? Do you see any JS errors in the console?
    – Anna_MediaGirl
    Oct 23 '13 at 0:16
3

Make sure that the particular Wygwam editor configuration assigned to this custom field has a chosen upload directory. To double check this go to...

Modules > Wygwam > Editor Configurations

...and in the editor configuration settings you will see a select menu labelled "Upload Directory" where you assign this.

2
  • This has been set for each configuration, and I've tested the file manager to ensure that uploading to that directory is possible.
    – kenyabob
    Oct 24 '13 at 19:24
  • Bummer, I thought that would be it. The Wygwam docs instruct you to clear your browser's cache after updating. Did you do that? If you don't want to clear your broswer cache, and you are using Chrome, you can try accessing the page using a Chrome Incognito Window (which will ensure your browser does not serve you cached content).
    – Alex Kendrick
    Oct 24 '13 at 20:47
2

I had this same problem and after some head scratching, found that for some reason the other member groups didn't have file upload priviledges. So, check:

Content -> Files -> File Upload Preferences -> Edit (select at least one location)

And check that at least one upload location allows the Member Groups to upload files.

enter image description here

1

The file upload option is now available from the LINK icon.

WYGWAM file upload

Then, if you click on Browse Server, you'll get the native EE file upload dialog window.

EE file upload

UPDATE

Just to confirm, when clicking on the image icon, I am seeing the Browse Server button as well. I'm running EE 2.7.2 and WYGWAM 3.2.1.

enter image description here

5
  • That's helpful. But the dialogue you're showing here is just for building links (upload and link to files), not for uploading and then embedding images right in the text as asked (as an img tag, not an a tag). The original post is showing the image dialogue (see linked screenshot in post), so I think that's what he's after.
    – Alex Kendrick
    Oct 31 '13 at 19:48
  • My bad. Updated to show it's not a bug, at least. What versions of EE and WYGWAM are you running? Oct 31 '13 at 20:11
  • 1
    Your Image Properties dialogue screenshot is exactly what I see, too, Stephen, running the same versions. @kenyabob, as Stephen said let us know by updating your original post what version of EE and Wygwam you are using.
    – Alex Kendrick
    Oct 31 '13 at 20:23
  • At least now I know what it should look like! I edited my original post, but I can also put it here. Im on 2.4.0 of EE, and 3.2.1 of Wygwam.
    – kenyabob
    Nov 1 '13 at 17:45
  • Were you ever able to figure this out? I'm running into the same issue with Wygwam 3.3.3 on an EE 2.9.2 site: no upload button for the client to upload images for adding to the post. Jul 8 '15 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.