1

I have been moving from EE file manager to Assets on a few sites without problems. The images turn up in the assets channel fields and all looks good.

But now I tried changing a field inside Matrix. It was EE file manager and I changed it to Assets. The image dosen't appear in the field but it shown in the Assets module (I have updated indexes and everything looks good there).

So basically I would have to go through every entry and select the file again in Assets and submit again to get the images back in order.

I can see the image in the exp_matrix_data folder. For example: {filedir_1}14958_Gravity.jpg But it is as I said not being displayed in the field in CP and not on the front end.

So my question is: Is it not possible to move from EE file manager to Assets inside a Matrix field?

I have EE 2.7.2 Matrix 2.5.8 Assets 2.2.1

Any ideas?

6
  • Update: checked the exp_matrix_data. The problem seems to be the "{filedir_1}" that is in front of the image name. If I edit an entry and select an image in the assets field then {filedir_1} is not in front of the image and everything looks good. Oct 24, 2013 at 0:51
  • From memory there is still linking going on in Assets tables, so you can't necessarily do a find/replace across the table. Anyone with actual experience should pipe in and tell me I'm wrong though. Oct 24, 2013 at 2:10
  • Yeah there is probably something else going on. Find/replace didn't solve it. Oct 24, 2013 at 9:19
  • exp_assets_selections is where you need to look to see if the files are indeed associated with your Matrix columns. Oct 24, 2013 at 13:15
  • ahh that explains it. There is nothing there - except for the one entry where I selected the image again and submitted. Oct 26, 2013 at 23:53

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.