2

My client is experiencing a really weird issue. When they are publishing or editing an entry with an Assets custom field it displays only a white box. They experience this issue in both their limited access member account and in my account which is super admin.

I however do not experience this in both my clients account and my super admin.

The client sees this issue on multiple computers, multiple browsers and again under both accounts.

The site is running EE 2.5.5, MSM 2.1.3 and Assets 2.2.1. It is using basic config (EE default), EE suggested .htaccess with 5 301 redirects.

In the config I have the following:

$config['assets_site_url'] = 'http://www.domain.com/';

Only stuff out of ordinary in the 2nd sites index.php is ce image related doc root and regex settings.

Under console in Ghrome there are two errors; both are:

Failed to load resource: the server responded with a status of 403 (Forbidden)

And seem to be dealing with Google Plus.

Not sure what else to check.

Thanks

  • 1
    Are they actually accessing the cp with www. in the URL ? – stuartmcd69 Oct 25 '13 at 0:45
  • It was user error with domain. – Tad Ward Oct 28 '13 at 16:41
  • I have the same problem with Assets. 403 forbidden. I have the proper domain setting on $config['assets_site_url']. It works fine locally but not on the server. Is there any other solution that might work? – user3811 Dec 20 '14 at 8:20
2

If you're getting HTTP 403, rather than the cross-domain error, then you might be hitting the incompatible session bug. Assets uses Ajax to do a lot of things and that is processed via Frontend by EE, so if your Control Panel Session and User Session types are not compatible, the Ajax requests will think you're not logged in.

Can you go in Admin -> Security and Privacy -> Security and Sessions and check settings for "Control Panel Session Type" and "User Session Type"? Can you try changing the first to "Cookies And Session Id" and the other to "Cookies only"?

This should fix this for you.

| improve this answer | |
1

Client was accessing the control panel via the subdomain and not the main domain.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.