0

I am using EE 2.1.3 within the MSM. I have a number of other sites already setup on this MSM and not having any problems. I tried to add a new site and got the "Unable to load site preferences" message.

I verfied that config.php, database.php for the MSM are set to 777, cleared the cache for the site and still got the error. So, for this sites' index.php file I made $debug = 1; Now it is showing:

A PHP Error was encountered

Severity: 8192

Message: mysql_escape_string(): This function is deprecated; use mysql_real_escape_string() instead.

Filename: mysql/mysql_driver.php

Line Number: 303

A PHP Error was encountered

Severity: Warning

Message: Cannot modify header information - headers already sent by (output started at /home/techmark/webapps/_system_ee2msm/.system/codeigniter/system/core/Exceptions.php:170)

Filename: core/Common.php

Line Number: 405

A Database Error Occurred
Unable to connect to your database server using the provided settings.

Filename: core/EE_Config.php

Line Number: 176

Any idea how to fix this? Like I said earlier all of the other sites on this MSM are working correctly.

Here is the site: http://friendsunday.outreachcs.com/

9
  • To be clear... are you seeing this error on all your MSM sites or just this one?
    – Anna_MediaGirl
    Oct 29 '13 at 16:40
  • Also, you are pretty far behind on your EE version... Is updating not possible?
    – Anna_MediaGirl
    Oct 29 '13 at 16:41
  • Are you using a dynamic configuration for your database settings, such as Master Config? i.e. the database settings are set dynamically based upon the host name Oct 29 '13 at 17:04
  • @Anna_MediaGirl - I am just seeing this on one site. Yes, we are far behind, but not time to update right now. Oct 29 '13 at 18:23
  • @JeremyGimbel - I don't think so. Oct 29 '13 at 18:24
1

Your error is due to your PHP version being too new for the version of EE you are using.

This function has been DEPRECATED as of PHP 5.3.0. Relying on this feature is highly discouraged. Link

Two options:

  1. Lower your PHP version to 5.2
  2. Upgrade to, at least, EE 2.3
7
  • But then why do all of the other sites on this MSM work? Oct 30 '13 at 13:57
  • did it not work? Oct 30 '13 at 13:58
  • I have about 5 five other sites that are working with this current setup. It is just this one that doesn't work Oct 30 '13 at 14:00
  • What's your PHP version? Oct 30 '13 at 14:06
  • I am using 5.2.17 Oct 30 '13 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.