I want to re-hash this issue: http://www.solspace.com/forums/viewthread/17419/

The error is:

Error Number: 1052

Column 'field_id_90' in field list is ambiguous 

It seems there was never a proper solution and I'm having the same issue. I can confirm (at least in my testing) that the issue is related to Matrix fields given a relevant value in Super Search.

I’m running EE 2.7.2, SS 2.1.3 and Matrix 2.5.8.

My two matrix fields are: services_about & ct_sub_sections

this works:


this doesn’t:

relevance=“title=1+services_tags=5+ct_tags=5+page_keywords=5+services_introduction=2+services_about =1+ct_about=1+ct_sub_sections=1+body=1+count_words_within_words”
  • Have you tried rebuilding the search index in Super Search? You can do that from CP => Add-Ons => Modules => Super Search => Utilities. You could also clear the cache in the Preferences section.
    – Solspace
    Nov 1, 2013 at 14:09
  • I am having a similar issue. Column 'field_id_43' in field list is ambiguous. SELECT t.entry_id, t.title, field_id_9 AS cf-pages-heading, field_id_10 AS cf-pages-subheading, field_id_4 AS cf-pages-intro, field_id_5 AS cf-pages-leftcol, field_id_7 AS cf-pages-rightcol, field_id_8 AS cf-pages-bottom-col-wide, field_id_12 AS cf-news-heading, field_id_13 AS cf-news-subheading, field_id_14 AS cf-news-excerpt, field_id_15 AS cf-news-content, field_id_18 AS cf-news-url, field_id_19 AS cf-toolkit-heading, field_id_20 AS cf-toolkit-subheading, field_id_26 AS cf-toolkit-intro
    – hfrancke
    Feb 12, 2014 at 0:44

1 Answer 1


I am experiencing the same problem where it seems to happen when "Is field searchable?" is enabled within the field settings containing the Matrix field-type (not sure why??!)...

I found a solution by changing line 7595 from

$select .= ', field_id_'.$fields[$key].' AS `'.$key.'`';


$select .= ', cd.field_id_'.$fields[$key].' AS `'.$key.'`';

Within mod.super_search.php. This seems to have fixed the problem where the table alias is added to the field.

Super Search V2.1.3

  • Seemed to work but I don't want to mark this as answered because it requires hacking the add-on. Can anyone from @solspace confirm? May 8, 2014 at 22:20
  • This is a correct solution, and it'll be available in the next version of Super Search :)
    – Solspace
    Sep 22, 2014 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.