4

I can't seem to prevent auto logouts from happening (EE 2.7.1).

I have set the config item 'admin_session_type' to 'c', which is confirmed in the control panel (reads: 'Cookies only' in Security and Session Preferences).

I have also set the 'cp_session_ttl' to 3 days in the config, but logouts happen after 30 mins or so.

I have even printed config object in a template AND the control panel to double check that it's set right, and it is (output: [user_session_type] => c [admin_session_type] => c [cp_session_ttl] => 259200).

Anyone know why I'm being logged out all the time?

3

On 30.01.2014 the EllisLab-Team published a patch which stops this behavior. Just upload a little Javascript and you are done - no more automatic logouts when you are idle!

Description + Download-Link here @ EllisLab Bugtracker

  • 1
    This should be the answer imo. The behavior is hard-coded, it's not tied to the config values at all. – notacouch Feb 7 '14 at 23:06
  • Thanks for the update. I've made this the answer, seeing how the fix came directly from EllisLab. – Maxwell Feb 8 '14 at 20:47
4

You should use "Stay Forever" extension.

http://johndwells.com/blog/stay-up-forever-take-control-of-ee-session-time-limit

http://devot-ee.com/add-ons/stay-up-forever

In this extension you can set control panel session length.

  • 1
    Thanks for the suggestion, I guess that I'll have to give it a shot. But it would be good if I could get the system to behave how it's supposed to without add-ons. – Maxwell Oct 31 '13 at 20:38
  • This has been happening for me as well since upgrading to 2.7.1. If it's an admin control panel login then it makes sense to auto log off in case of any security issues. But I agree there should be something built-in to Exp Eng that would control a time-out preference. I've made the config file setting indicated below and will have to see how it goes. – Bob Foster Dec 4 '13 at 17:50
3

I found the solution to my problem. The logouts were caused by the login reminder feature, which detects if a session expires and allows you to quickly log back in. This quick login feature eventually expires and completely logs you out of the control panel.

I don't see why this feature should be active when I'm using cookies instead of sessions, and I don't think it's getting my 3 day session correct, but anyway, there's a hidden configuration variable to disable it:

$config['login_reminder'] = 'n';

I haven't been auto logged out all day!

2

there is a hidden variable; john, the guy who has written this addon 2 years ago (and btw. is responsible for the most nice Minimee), has mentioned it.

in the file system/expressionengine/config/config.php try

$config['cp_session_ttl'] = 60000;

the number is the time in seconds.

  • Thanks for the reply, but I did mention in my description that I have that value set to 3 days (259200). – Maxwell Nov 10 '13 at 0:38
  • ah ok, I somehow mixed this up with the 'user_session_ttl' ... since I set the cp_session_ttl to 600000 everything is working for me (it seems, did it yesterday) – BNetz Nov 10 '13 at 14:20
  • inbetween I have figured out that the changing of this variables hasn't helped. problem still persists. – BNetz Nov 29 '13 at 16:43
  • Yes, I still can't figure out a way around this problem, it's driving me nuts. – Maxwell Dec 1 '13 at 22:22
  • And we paid for a software which lacks an absolutely elemental function - to keep logged in. – BNetz Dec 2 '13 at 19:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.