1

I'm trying to build out a blog in EE, and even though i'm still a bit confused by some things my biggest issue is that all posted comments via {exp:comment:form} default to open.

So i have a channel called "our_blog" and below are it's preferences.

  • Allow comments in this channel? Yes
  • Require membership in order to post comments? No
  • Require email address to post comments? No
  • Moderate Comments? Yes

So i assumed, that having it set to "Moderate Comments" would mean that all comments posted to this channel entries would be defaulted to either closed or pending. But for whatever reason they keep defaulting to open, so as soon as someone posts a comment it shows up on the front-end. This is a no-no!

This is my form

{exp:comment:form channel="our_blog"}
      <label for="name">Name:</label> <input type="text" name="name" value="" size="50" />
      <label for="email">Email:</label> <input type="text" name="email" value="" size="50" /><br /><br />
      <label for="comment">Comment:</label><br />
      <textarea name="comment" cols="70" rows="10">{comment}</textarea><br /><br />
      {if captcha}
          <label for="captcha">Please enter the word you see in the image below:</label><br />
          <p>{captcha}<br />
          <input type="text" name="captcha" value="{captcha_word}" maxlength="20" /></p>
       {/if}
       <input type="submit" name="submit" value="Submit" />
{/exp:comment:form}

I've googled and googled, but to no result! Thanks for any help and advice in advance!

1

If the members who is testing the comments are in the group super-admins or another one which has been set to exclude its members from the comment moderation, the status of their comments will always be open.

  • I tried it as guest also, it defaulted to open. And that Guest member groups setting for Exclude member from comment moderation is YES. It defaults to Open whether that setting is YES or NO. – ipixel Nov 1 '13 at 3:18
  • 1
    I take that back, i guess the pages wasnt refreshed when i tested. I set Guest as NO and it works! THANKS! – ipixel Nov 1 '13 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.