I recently discovered that member pages for my EE site are showing up in Google search results, even though I'm not currently using members (beyond super admins) and I have no public member page templates.

Here's an example of the page I'm seeing: http://www.weddingwise.co.nz/member/1

Is there any way to hide all pages with "member" in segment1 so they are not visible to public or to Google?

1 Answer 1


Under Members -> Preferences in the control panel, you can set the Profile Triggering Word (see docs) to % which will make them completely inaccessible from the frontend.

Another technique is to configure it randomly in the config.php like this:

$config['profile_trigger'] = rand(0,time());
  • Great thanks. Your first option worked like a charm. Commented Nov 4, 2013 at 3:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.