I had been using EE 1.7 and I could always download a loaded image to check for a large size or formatting problem from the backend. Now with 2.5.5, I am not able to download the images or otherwise see what might be the problem. How do I find out what might be wrong with the images?

  • Can you elaborate? Are these the only two images missing? Other ones succeeded? Do you see the images listed in EE's File Directory view? Are there any errors along the way? Are you able to replicate? Commented Nov 4, 2013 at 10:29
  • Also, did the user upload the images from the EE control panel or front-end? Commented Nov 4, 2013 at 10:52
  • The page is set up to accept up to 7 of a certain image type. Five of the images loaded okay (by the user), while two appear in the EE dashboard but not on the front end. 1) I first deleted one of the "working images" and uploaded another from one of my files. That worked fine. Commented Nov 4, 2013 at 23:31
  • Next, I 1) deleted one of the "working images", saved the page and just left the place for an image blank. But this resulted in something I did not expect: the image was not deleted on the frontend, or backend. Commented Nov 4, 2013 at 23:34
  • In response to "Do you see the images listed in EE's File Directory view?" A thumbnail is loaded in EE, but a file by that name does not appear in the directory view. SO, it looks like somehow the files did not load, but the thumbnail did??? I have contacted the user to try to get the entire image file for these two. Commented Nov 4, 2013 at 23:46

2 Answers 2


How do I find out what might be wrong with the images?

There could be one (or more) of several things going on. Here are some things to check:

  1. Verify that you can upload an image to the upload directory in question. Content → Files → File Manager → click "Upload File" button and upload to your directory. If you succeed then your images are uploading just fine you may have another issue. If the upload doesn't work continue...

  2. Verify you can synchronize the file upload directory in EE. Content → Files → File Upload Preferences → click the synchronize icon for the directory in question, then Submit on the following page. If you have trouble here, continue...

  3. Make sure your path to this directory is correct in EE by clicking the Edit link on the File Upload Preferences page

  4. Make sure the folder exists on the server and has the proper permissions (most likely chmod 777).

  5. Repeat step 1 to see if any changes you made worked.

  6. If a Super Admin can upload but another member group cannot, check the member group's upload permissions via the same File Upload Preferences.

This is not exhuastive, but should help you in locating most issues or ruling out the most basic of issues normally encountered with file upload issues.


I came across a similar thing this week.

A client had uploaded IMAGE.jpg and image.jpg and had chosen on to display in an entry. EE couldn't distinguish between them and no matter which was selected the uppercase image showed first. Servers (rightly) see them as two files - all paths being case sensitive.

However it appears EE 2+ doesn't see them as two images (in our case using a grid and file fields) so we've had to do some tinkering to get them to display (deleting or renaming then updating entry).

This dual naming issue with upper/lower case could be the reason possibly?

  • Thanks for the comment, that is helpful to know. My case, however, is not related to file names, but seems to be something in the file manager. Commented Nov 5, 2013 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.