0

I just updated an EE site from 2.4.0 to 2.7.2. Now going through and updating (many) plugins. I just updated Matrix from 2.4.3 to 2.5.8 and I get the error below while trying to click on Matrix in the Fieldtypes page in the CP. Any help would be awesome, thanks!

A Database Error Occurred
Error Number: 1060

Duplicate column name 'is_draft'

ALTER TABLE `exp_matrix_data` ADD `is_draft` TINYINT(1) UNSIGNED DEFAULT '0'

Filename: third_party/matrix/ft.matrix.php

Line Number: 509
1
  • I removed your question/comment about Assets upgrade as it's not related to your main question. You will need to try the Assets upgrade and post another question if you have problems you can resolve on your end.
    – Anna_MediaGirl
    Nov 4 '13 at 19:42
2

See this post for info Matrix (2.5.8) update database error

Sounds like it is the same or similar problem. I had this once and the info there was enough to go into the database and sort out the issue.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.