4

We're using Store 2.0.1 on EE 2.7.2 and trying to figure out how to get the UPS shipping extension working. I've read and re-read the docs but I'm clearly missing something. :/

Docs say:

The UPS Shipping extension will automatically add shipping method options to your checkout. To display the shipping options inside your checkout tag, use the {field:shipping_method} variable.

So, we have {field:shipping_method} in our {exp:store:checkout} tag but all I see is a drop-down with no options. We don't have anything set up in the Shipping Methods of Store's settings. Have I misunderstood the docs?

2

I had the exact same issue and if it was not for Angie, I would have never figured it out.

"The solution for us ended up being ridiculously simple. Under the UPS Settings (in Extensions), make sure that the Source Country is correct. I had something like "United States" but it should be US."

I had exactly that, "United States", and changing it fixed the problem.

| improve this answer | |
  • Just wanted to point out that Expresso support helped quite a bit in nailing this one down. I also would have posted the answer had I known this question was no longer on hold or whatever. :) – Angie Herrera Jan 23 '14 at 22:54
  • US in the Source Country is not working for me. Store version 2.2.0 – JackTheKnife Feb 27 '14 at 21:06
1

The docs might be a bit out of date for the latest version of Store. You will want to goto Add-ons > Extensions and enable the UPS plugin. Once it is enabled you will want to click on the settings for the UPS Extension and enter your UPS details and select the boxes for the types of shipping you would like to offer. Once you have done that the {field:shipping_method} should populate on the front-end of the site now.

Having said that you will need to make sure that you have a users shipping details before you try to calculate a rate.

| improve this answer | |
  • Hm, have all that set (UPS details) and have a couple of fields to grab the country and zip code. Still nothing. :/ – Angie Herrera Nov 4 '13 at 21:53
  • I don't know of any UPS specific errors/bugs for 2.0.1 but are you able to upgrade to the latest version of Store 2.0.4 ( exp-resso.com/docs/release_notes.html#store_204 ) – Justin Long Nov 4 '13 at 22:24
  • Okay, upgraded to 2.0.4. Still no dice. Also tried reinstalling the extension. Additionally, when I tried to disable the UPS extension, I got that green icon in EE's CP but the extension still shows as enabled. – Angie Herrera Nov 4 '13 at 23:49
  • It might be best to email support@exp-resso.com as it sounds like something that will need to be troubleshooted with server access. – Justin Long Nov 5 '13 at 3:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.