1

EE v2.5.2

Messages sent via the communicate panel work OK and messages are delivered successfully.

But if an address is entered in the cc or bcc field then we get PHP error messages and the mail isn't delivered.

"For security reasons, extra headers for the mail() functionhave been disabled, please contact support for more information. Filename: libraries/Email.php Line Number: 1537"

"Cannot modify header information - headers already sent by (output started at /path/etc/etc/system/codeigniter/system/core/Exceptions.php:170) Filename: core/Common.php Line Number: 412"

Anyone got any ideas what to try?

2

"For security reasons, extra headers for the mail() function have been disabled, please contact support for more information"

It sounds like your web host has disabled parts of PHP's mail function. You could try using one of the other mail delivery options (e.g. SMTP), or otherwise I would get in touch with your web host and ask them what they recommend.

| improve this answer | |
0

This sounds like a bug so the first thing to try is update your ExpressionEngine version to the most current version which is 2.7.2

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.