I have a site we are setting up on EE 2.72, and without realizing there was a known issue it i started using the Field Editor add-on to add fields. It was throwing some errors here and there but seemed to save things ok.

The issue I'm having is that now I'm getting some fields that just won't show on the publish page layout. I the edit layout sidebar they show as empty squares. When you click on the squares it switches to the eyeball but doesn't actually show in the layout.

enter image description here

I tried removing the field and adding it without field editor, removing field editor, and even going into the database exp_layout_publish table and removing the field layout json completely but no luck?

Any ideas?

  • 1
    Have you tried resetting the channel's publish layout using the link below the field list in the sidebar, then reloading the edit screen? Nov 8, 2013 at 17:42

1 Answer 1


Sounds like you need to reset the Publish Layout. Select the member groups for which the layout should be reset and click the "Reset Layout" button. Then refresh the browser window. You'll then need to rebuild your Publish Layout.

enter image description here

  • Yes! that seems to do it, not sure how it got all messed up but that seemed to clean it up, thanks! Nov 9, 2013 at 16:14
  • I've been seeing similar issues on EE 2.7.0--and I'm also using Field Editor. So, it's maybe a Field Editor-related issue. But, resetting the layout--or, just saving the layout, does reset things and then all is well.
    – Jay F
    Nov 11, 2013 at 0:51
  • 1
    You are my HERO!!! I've literally been wreaking my brain all day long!
    – user3844
    Dec 2, 2014 at 15:37
  • You're welcome:) Vote the answer up if it worked for you.
    – Anna_MediaGirl
    Dec 2, 2014 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.