3

Something has happened to the Live Look links in the entries within my control panel. After submitting a new article, the Live Link (link to a preview of my article) looks like this:

https://mysite.com/?URL=https%3A%2F%2Fmysite.com%2Ftemplate_group%2Flivelook%2F185

instead of like this:

https://mysite.com/?URL=https://mysite.com/template_group/livelook/185

This is new. I'm not sure why it's now happening. I'm on EE 2.5.3.

Any thoughts on how to get the normal link back?


Additional info:

This problem is not only happening for me with live sites. If I install a completely new EE 2.5.3 in MAMP with no extensions I still see this problem.

  • 1
    So I take it that it's redirecting to the encoded URL too? – Justin Kimbrell Dec 15 '12 at 18:13
  • I don't know if it will work, so I'm not writing it up as an answer, but take a look at this question: expressionengine.stackexchange.com/questions/1615/… It may solve your encoding problem. – nonprofit_tech Dec 15 '12 at 19:40
  • That's correct, Justin, it's redirecting to the encoded URL too. Tricky. – John Morton Dec 16 '12 at 15:45
  • nonprofit_tech, thanks for the link. Unfortunately my 'global_xss_filtering' is already set to false. :-/ – John Morton Dec 16 '12 at 15:47
3

Thanks to both Dom Stubbs & Media Girl. You spurred me to deeper investigation and I've got a solution working for me.

It looks like when the 2.5.3 update started encoding the Live Look links in my control panel, it exposed a problem with my server not handling those links properly. What I failed to mention was the error the link was showing in my browser which was "The URI you submitted has disallowed characters."

Before the Live Look URL was encoded, I didn't have this issue, but now I do, or did.

I've had the particular site I'm speaking of on Dreamhost which seemed to only work properly when I'd set the "uri_protocol" in my config file to "QUERY_STRING". My setting of the uri_protocol was related to my desire to get rid of the "index.php" in my URLs. I worked on the htaccess file so long ago, I don't recall the exact reasoning behind where I ended up.

Regardless of why I got to the point of use "QUERY_STRING", I set it back to "AUTO", which is the default, and my LIVE LOOK links are working in the new encoded version. I suspect something has changed with my Dreamhost PHP set up in some automatic update that I didn't notice that allowed me to stop using "QUERY_STRING."

So, in short, changing "uri_protocol" in my config file from "QUERY_STRING" to "AUTO" solved the problem with the encoded URL not working for me.

| improve this answer | |
1

From the 2.5.3 changelog:

Fixed a bug (#18071) where masked URLs in the control panel were not URL-encoded to protect characters like ampersands.

This should make the Live Look redirects more reliable. Are yours not loading correctly?

| improve this answer | |
  • I think this may be the issue. I think I've gotten to the bottom of my issue now and I've got it working. I will post the solution here. – John Morton Dec 17 '12 at 15:02
0

The first step to troubleshooting this would be to disable Extensions by adding this to your config.php file or by changing the config to "n" if it already exists in config.php.

$conf['allow_extensions'] = "n";

This will eliminate code in one of the extensions as part of the problem.


If this fixes your links, you'll know one of the Extensions is the problem. Unfortunately, you'll need to uninstall each Extension one at a time to figure out which one is the problem. Uninstalling the Extension will cause you to lose the settings for that Extensions so you'll need to re-setup settings when you install it again. This is a pain but there is no way around it. Make a backup of your database before starting this process so you can revert back if needed.

Also, the issue might be caused by the Extension's priority for the extension hook it's using (1 => First, 10 => Last.). You can make changes to the priority by manually editing the "priority" column in the "exp_extensions" table in the database. Looks at Extensions that will affect the Edit tab if that's where the problem URLs are visible.

| improve this answer | |
  • Disabling all extensions doesn't change the behavior. I amended my initial post with more info now too. Even a completely clean install of EE 2.5.3 causes this to happen. I think Dom Stubbs may have figured out this is an EE change in behavior. Dang. – John Morton Dec 17 '12 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.