3

I turned off the site in the config panel, General Configuration , Is system on? = no. Inside the config file, it’s set to no too. But even if it’s set to no, the site still online. I can still view the site when logged out.

On a fresh EE install System Offline not working works, so i guess it would be caused by a Plugin conflict.

Does someone had already had this issue ??

i’m using EE 2.7.2

Thanks,

Stéphane

5

I was almost certain that Custom System Messages was causing this problem.

The template offline message could be set in the preferences, but it was not. As Custom System Message has a greater priority over EE offline template, and no template was set, it was not working.

The template was set inside Custom System Message

The problem is solved.

|improve this answer|||||
  • Thanks - this just solved exactly the same problem for me too. – Jules Matthews Dec 8 '13 at 21:03
4

is not possible that some add-on can be affected on this. You need to be sure, that you are not login as SuperAdmin. Because Super Admin can see site even in offline.

|improve this answer|||||
4

You shouldn't see the site in online mode if you have set $config['is_system_on'] = 'n'; in your config.php file.

If you are seeing the site, I'd guess one of the following is true:

  1. You are editing the wrong config.php file

  2. You are still logged into the control panel as a SuperAdmin. Clear browser cookies to be sure and confirm that you see the login screen when loading domain.com/admin.php

  3. You have something other than $config['is_system_on'] = 'n'; set in your config file, perhaps a misspelling?

  4. You have multiple instances of $config['is_system_on'] set in your config file... one near the top turning it off and one later turning it off.

  5. The EE cache needs to be manually cleared via FTP

|improve this answer|||||
1

After put your site offline, clean up the system cache. Open another browser and check the site.

You also can copy system/expressionengine/utilities/offline.html to your web root directory and rename it to index.html. If your server is configured to look first for html files, the site goes offline.

Make sure your server isn't sending a long cache time of html or files without extension to the browsers. On Nginx, look up for the expires setting. On Apache, look up for ExpiresByType text/html.

|improve this answer|||||
1

Thanks a lot for the replies!!

I set my $config['is_system_on'] = 'n'; in my config.php file.

The cache is off, it could not cause this problem. And I cleaned the cache of all the browsers.

The problem is caused by a addon, extension, module, but i don't know wich one. So I found a solution, disabe all the extensions:

$config['allow_extensions'] = "n";



With $config['is_system_on'] = 'n'; and $config['allow_extensions'] = "n"; the offline template is displayed.

Now i have to find which is the extension that prevent the system to be turned off.

|improve this answer|||||
0

Recently I spent an hour trying to sort out a similar problem and had forgotten I had Dev Demons Smart Switch installed (which I was using for the first time).

Great add-on by the way.

http://www.devdemon.com/smart_switch/

|improve this answer|||||
  • Hi Jules, Custom System Message is a great extension too. Really with many modules installed more complex are the settings. – Stéphane Nov 20 '13 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.