1

I'm getting this issue with a new MT GS Server and have yet to resolve the problem despite reading he various recommendations on EESE. My database.php file is set to point to my config.php file where I've placed all my DB settings in a DRY setup. Both have been tested with 755 and 777 with no change in results. I can log into the db with PHPMyAdmin and Sequel Pro but when I try EE and a simple test script I get the above error. Any ideas why I can connect with PHPMyAdmin and Sequel Pro but not through PHP? Any other suggestions to try to resolve a db connection? Anything to keep in mind when talking to tech support at MT?

6
  • 2
    When I see this message it always turns out to be a database connection issue. Is the hostname correct for your database? If you're using a multi-environment setup based on the current url, are you using a staging address that isn't included in the config?
    – Dylan
    Nov 19 '13 at 3:35
  • URL (it is a multi-environment setup), hostname, username, and password have been checked and re-checked, and re-re-checked in both config.php and my test db.php file. Same credentials used in Sequel Pro and PHPMyAdmin. Nov 19 '13 at 3:54
  • 1
    The config file and database should have file permissions of 666 not 755 or 777 Nov 19 '13 at 4:58
  • If file permissions don't help, can you show us your config.php file's db settings? Nov 19 '13 at 10:47
  • The settings are identical to those on other sites I've built with the exception of changing the user, host, etc. Some of these sites are on MT GS servers as well and run just fine. It's also the same config that runs my local dev environment and a temporary staging site I built on a subdomain on our GS host. My guess is a config issue on the MT server but I was hoping there might be a little more insight into how people resolved this issue that similar posts seem to lack. Nov 19 '13 at 13:41
2

Turns out it was a password issue. MT didn't like the original password I entered for some reason. Changing it fixed everything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.