0

Running into some serious issues with CartThrob. All of a sudden I am getting this error when I add an item to the cart and try to view cart or checkout:

It was working last night and sometime over night it all fell apart. Running EE 2.7.1 and CT 2.4

Error Number: 1062
Duplicate entry '465628' for key 'PRIMARY'

INSERT INTO `exp_cartthrob_cart` (`cart`, `timestamp`, `url`) VALUES ('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', 1384949211, 'http://domain.com/checkout/checkout')

Filename: third_party/cartthrob/models/cart_model.php

Line Number: 79
  • I found this blogs.vinuthomas.com/2008/06/18/… changed the field from int to unsigned bigint which fixed the problem for them For me, it didn;t seem to work but once I changed it back to INT the error seemed to go away. (Hopefully for good) – Peter Eastwood Nov 20 '13 at 16:43
  • Please post your solution below as an answer and accept it as correct. The more details you can provide the better for the next person who runs into this. – Anna_MediaGirl Nov 21 '13 at 2:14
0

I found this blogs.vinuthomas.com/2008/06/18/… changed the field from int to unsigned bigint which fixed the problem for them For me, it didn;t seem to work but once I changed it back to INT the error seemed to go away. (Hopefully for good)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.