1

I've created a /404.group/index.html that contains my desired 404 page. In Design ‣ Templates ‣ Global Preferences, I've set my 404 to 404/index.

When I go to domain.com/some-crazy-made-up-url, I do not get the 404 page. However, I do see it when I go to domain.com/404.

What am I doing wrong? I have Enable Strict URLs set to "yes".

5
  • Do you get a blank screen or does it render another template? Try enabling Error Reporting and Template Debugging to shed more light. ellislab.com/expressionengine/user-guide/cp/admin/… – Judd Lyon Nov 21 '13 at 5:39
  • It renders the homepage template. I'm not sure if I see anything odd in template debugging. Nothing seems out of place. – ExpressionEngineNewbie Nov 21 '13 at 9:36
  • do you have strict url's set to no or yes? – Jelle Dijkstra Nov 21 '13 at 15:26
  • "yes", per my original post. – ExpressionEngineNewbie Nov 21 '13 at 20:47
  • 3
    If you haven't worked this out, yet, can you revise your question and include the exp:channel:entries tag on your home page? Setting require_entry="yes" as a parameter, as well as having {if no_results}{redirect="404"}{/if} might be needed. – Jay F Dec 9 '13 at 1:47
2

Check your htaccess file. It's possible you have a 404 redirect statement there too which should be removed.

2
  • Nothing in htaccess that relates to 404. I checked the server response for the page I expect to return a 404; it is returning a 404 (used Chrome's web developer toolbar to verify). – ExpressionEngineNewbie Nov 23 '13 at 7:35
  • Try disabling extensions in index.php to see if one is causing the issue... – Anna_MediaGirl Nov 25 '13 at 1:59
-1

Is this not a simple issue with using .html and not .php? If you create the 404 group page as 404.group/index.php see what you get when you throw in a random url.

1
  • The correct extension for ExpressionEngine templates is .html. – Jeremy Gimbel Dec 7 '13 at 0:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.