1

I have found that when using the sample templates that come with the Exp-resso Store and Zoo Visitor add-ons on EE 2.7.2, I get the following PHP error:

A PHP Error was encountered

Severity: Notice

Message: Undefined property: EE::$typography

Filename: core/EE_Output.php

Line Number: 308

Fatal error: Call to a member function parse_type() on a non-object in [MYPATH_SYSTEM_PATH]/expressionengine/core/EE_Output.php on line 308

Commenting out line 308 of that file:

$data['content'] = $EE->typography->parse_type(stripslashes($data['content']), array('text_format' => 'xhtml'));

Then produces a handled error:

The model name you are loading is the name of a resource that is already being used: addons_model

The error is thrown from CodeIgniter's Loader on line 194:

if (isset($CI->$name))
{
    show_error('The model name you are loading is the name of a resource that is already being used: '.$name);
}

Commenting that line out makes everything run fine.

I've searched for uses of addons_model and the only reference I can see to it are either in third party addons (neither of which are enabled and neither of which are Store or Visitor), or EE's core. Obviously I don't want to be hacking at the core of EE or CI but this seems like an EE bug to me.

Has anybody else seen this problem or have a resolution?

4
  • Which versions of Store and Zoo Visitor are you running? Have you tried re-uploading all EE/Store/ZV files in case anything is corrupt or missing? Also if you disable (individually) either Store or ZV, does the problem go away? – Adrian Macneil Nov 23 '13 at 0:05
  • Is this happening on all the templates? Have you reduced code to narrow down what in the templates is triggering the error? – Anna_MediaGirl Nov 23 '13 at 3:10
  • I have stripped Store's product.html template down to a single line: "{exp:channel:entries}{/exp:channel:entries}" and still the same error. So I think is EE, not Store. Will try Adrian's suggestion of restoring all core files – Russ Back Nov 25 '13 at 7:54
  • Found it. The LibrarEE module (1.0.6) was the culprit. An update to the latest 1.07 fixed it. – Russ Back Nov 25 '13 at 8:30
1

After some help from @Adrian Macneil, I tried installing Store and ZV again. No luck, so with Store installed, started removing all OTHER add-ons and tracked it down to version 1.0.6 of LibrarEE. An update to 1.0.7 sorted it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.