2

I am having an issue where if users try to access a page that doesn't exist within a template group, it displays a blank page instead of the 404. I believe this is due to the fact that the template groups have an index file in them that has no code. I would like to have a 404 page appear any time someone accesses a URL that doesn't exist within my site but I believe I have to remove the index files from my template groups for this to happen.

Does anyone know how I can accomplish this or a different solution to getting my 404 page to display instead of the blank white page?

5

You can't delete index templates, so you'll have to include {redirect='404'} on those templates to force them to 404.

| improve this answer | |
0

Check out the EE docs on 404 pages, to get a understanding on how they work and how to set it up. Also I would remove the index files, that is just personal preference for me. You can do this by going into the Template Manager(Design -> Templates -> Template Manager). And delete each index file you don't want.

| improve this answer | |
  • Thanks for the response, that's what I thought I should do but there is no delete option next to the index files in any of the template groups. I have the 404 page configured correctly because it works on nonexistent URLs from the root of my site like: mysite.com/abcd but they don't work on any pages that are within a template group such as mysite.com/about/abcd – APAD1 Nov 22 '13 at 21:09
  • 1
    Sorry forgot about that, I am able to do it because I use Mountee and a Text Editor which it allows me to delete Index files. You can setup some code within the index to either forward them to another page, or integrate some logic with a 404 to stop them from going to those pages. – Justin Clarke Nov 22 '13 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.