3

After checking the WorldPay settings numerous times I still can't get it to redirect back to the site after a successful test payment.

I know the settings are ok in WP as I have checked against another setup for a site that is live and working fine.

Once payment has been made WP gives me a blank page with browser page title of 'Domain Registered', so it looks as though it's just not re-directing at that point.

Has anyone experienced anything similar with success in fixing it?

EE version is 2.7.2 and Store 2.0.6

Any help appreciated, thanks.

  • Have you called and asked WP to tell you what logging information they have for your transactions? It can you tell you quite a lot about what might be going? – JohnWBaxter Nov 30 '13 at 21:56
  • Hi John, thanks for the comment and it's a good point. I have been waiting for someone at WP to get back to me so I'll ask for this information too and see what's there. – Wes Dec 2 '13 at 8:58
2

Is your site available to the outside world (system is on and no passwords or funny business preventing people from accessing your test site?).

Have you followed the instructions here? https://exp-resso.com/docs/payment_gateways.html#worldpay

You need to make sure the payment response URL in WorldPay is set to <wpdisplay item=MC_callback>.

Also, have you disabled secure forms? Since EE 2.7 that seems to mess up pretty much everything related to off-site payment gateways. You can disable it in the CP under Admin > Security & Privacy > Security & Settings by setting "Process form data in Secure Mode" to "No".

| improve this answer | |
  • Hi Adrian, thanks for your reply. I have checked the settings in both EE and WP many times and compared with a working live site using an earlier version of the Store add-on with WP and still no luck. I have also just turned off the setting you mentioned and still I get the same blank page. I have also emailed Store support email but with no reply yet. – Wes Nov 27 '13 at 8:48
  • Happy to follow up via email but I can't see your ticket. Did you get an immediate response saying your message was received? – Adrian Macneil Nov 27 '13 at 9:38
  • Great thanks, but no I didn't get a response. I will try and send it again now... sent but no immediate response? – Wes Nov 27 '13 at 9:55
1

Ok, this has been resolved now!

It turns out that the cause of the problem was an index.html holding page not allowing the redirection to take place. A simple fix in the end (remove the html file), which would have been easier to spot with the transaction log data from WorldPay that they failed to send after numerous requests.

Anyway, hopefully this answer will help anyone else with a similar issue in the future!

| improve this answer | |
  • I've seen this happen on sites where the site is set to "offline" but admins can view the site, but just like in this case an outside request does not have an admin cookie, so they hit the index.html file instead. – Brian Litzinger Dec 6 '13 at 15:25
0

Without seeing your code, we can only guess. I'd guess you need to add the domain to your return address:

{exp:store:checkout return="https://domain.com/order/ORDER_HASH"}
| improve this answer | |
  • Thanks Anna, however I have already tried using an absolute return path, but still no joy I'm afraid. – Wes Nov 26 '13 at 17:03
  • Dig into the payment gateway file and echo out what Store is sending to WorldPay... Is the URL correct? – Anna_MediaGirl Nov 26 '13 at 17:05
  • 1
    The return URL doesn't need to be absolute... Store automatically adds the current site domain, I think this would actually break it since you would end up with the domain twice. – Adrian Macneil Nov 26 '13 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.